Calibre 5.0 nur ab Windows 8?

  • Habe eben Calibre 5.0 runtergeladen und wollte es instalieren. Leider kommt die Meldung das es nur ab Windows 8 installiert werden kann, ich habe aber nur Windows 7/64 und kann nicht auf Win 10 umsteigen, weil einige meiner (alten) Programme nur bis Win 7 lauffähig sind. Mist....

    Ob es noch ne neue Calibre Versin geben wird die unter 7 lauffähig ist? Ich hoffe es.

  • Ob es noch ne neue Calibre Versin geben wird die unter 7 lauffähig ist? Ich hoffe es.

    Das glaube ich eher nicht.

    Ich gehe wieder auf die alte Version, da viele Plugins noh in Python 2 geschrieben sind

  • Vielleicht lohnt es sich auf Win10 zu upgraden, wegen den vermeintlichen Sicherheitsupdates und die Win7 Programme aus einer VM heraus laufen zu lassen?

  • das MSI-Paket mit einem Hex-Editor (zB mit HxD Portable) öffnen.

    nach dem String "VersionNT >= 602" suchen.

    "602" (Win8) zu "601" (Win7) ändern, speichern, installieren, ...

  • Hallo aladoro,

    etwas spät meine Rückmeldung, sorry!

    Danke für den Tipp!

    Habe es (mit Uedt) probiert und Calibre 5 läuft auf meinem alten Win7!

    Jetzt bin ich nur gespannt ob etwas nicht läuft.... notfalls wird wieder die letzte Version <5 installiert.


    Ist es denn zu erwarten das etwas nicht funktioniert, worauf sollte ich evtl achten?


    Gruß Christian

  • kann nachvollziehen dass Mr Goyal Win7 nicht mehr unterstützen will, MS tuts ja auch nicht mehr ...

    nachdem ich mir ergoogelt hatte wie MSI-Installer die Win-Version prüfen, war es simpel, den Installer zu patchen. hoffe es bleibt so ...


    hab in den letzten 2W mit V5.x gearbeitet wie anhin (Viewer, Tagger, Editor, Konverter): bisher lief alles wie gewohnt, keine Abstürze, Fehlermeldungen, nix. also scheint es keinen *technischen* Grund zu geben, Win7 "offiziell" aussen vor zu lassen ...


    have fun, lG, andreas

  • Leider funktioniert Alf nicht mehr....

    das ist so, aber nicht eine Frage von Win7 oder nicht, sondern dass generell Python2-Plugins unter Calibre 5.x nicht mehr funktionieren ...


    "Bitte melden Sie sich an, um diesen Link zu sehen. ... apprenticeharper released this on Jun 18;

    This release DOES NOT work with calibre 5.0. Stick with calibre 4.23 for now if you need DRM removal."

    (Bitte melden Sie sich an, um diesen Link zu sehen.)


    "Sep 26, 2020 ... Starting on Version 7.0"


    abwarten ...

  • Ich warte....


    Habe Calibre Version 5 mit der Systemsteuerung deinstalliert und die letzte 4er Version installiert.

    Und bin schwer begeistert, ohne weitere Maßnahmen funktioniert alles so wie vorher!

    Ich hatte befürchtet, wieder vieles neu installieren zu müssen.


    Das ist mir wieder eine Spende an Calibre wert.


    Ohne Calibre würde mir der Umgange mit ebooks deutlich weniger gefallen.


    Von diesem Programmverhalten können sich andere Softwerker ne dicke Scheibe abschneiden,

    Z.B. die von Firefox, die mit der letzten Version das Prog völlig verhunzt haben....